HOME > Chowhound > Site Talk >

Discussion

Using "back" does not go back, it opens the page anew

Just this afternoon I've noticed when I open a thread to read it, then right click to open a dialog box where I select "Back", the page I was on is not returned to the state it was when I opened the thread, rather it is completely refreshed. This is new behavior, and it is not the normal behavior of back. I prefer a page not be refreshed unless I refresh it.

  1. Click to Upload a photo (10 MB limit)
Delete
  1. Hi janniecooks.

    Is this still happening? It looks like you ran into the problem while we were releasing some updates to the site, so it might've just been a temporary glitch.

    Thanks for your report.

    2 Replies
    1. re: DeborahL

      Deborah, thank you for a quick response. After posting the issue, I'd not used CH until now. It is fixed, thank you very much.

      1. re: janniecooks

        So glad, thanks for letting us know. And sorry for the glitch.

    2. The back button is malfunctioning again. Open a thread, read the posts, hit back and the page is refreshed as if I opened it. I would expect back to return the page to the state it was in when I opened a thread.

      1 Reply
      1. re: janniecooks

        i'm getting it too - noticed it because I was going 'back' and when I got to the previous page, I was not logged in anymore.

      2. Thanks for your reports, we'll take a look.

        1. When I hit the back button it doesn't do anything at all. Chowhound is the only site that acts that way (that i've tried).

          1. I never use the back button; with Chowhound I find it much easier to right click the link to open it in a new tab.

            1. We're not seeing this on our end. Can any of you provide further details, such as what board you started on, what thread you were reading, how far down the page you read, what operating system you're on, and what browser you're using?

              Also, just to confirm, this is the browser back button, not the "Back to Board Name" button at the bottom of the thread?

              Thanks.

              2 Replies
              1. re: DeborahL

                Right-clicking to open a menu/dialog box that had Back at the top, followed by forward, reload, etc., then selecting Back caused the page to reload, not go back. It doesn't seem to be happening to me now, must have been another of those fleeting maintenance upgrades that happened at the time I posted about it again a couple days ago. It happened on the home cooking board that day, as I recall, not on other boards. but memory being what it is...

                1. re: janniecooks

                  Thanks for the details. Issues that are intermittent and/or that can't be reproduced on our end are difficult to diagnose, but we'll keep an eye on it.