HOME > Chowhound > Site Talk >

Discussion

Using "back" does not go back, it opens the page anew

Just this afternoon I've noticed when I open a thread to read it, then right click to open a dialog box where I select "Back", the page I was on is not returned to the state it was when I opened the thread, rather it is completely refreshed. This is new behavior, and it is not the normal behavior of back. I prefer a page not be refreshed unless I refresh it.

  1. Click to Upload a photo (10 MB limit)
Delete
  1. Hi janniecooks.

    Is this still happening? It looks like you ran into the problem while we were releasing some updates to the site, so it might've just been a temporary glitch.

    Thanks for your report.

    2 Replies
    1. re: DeborahL

      Deborah, thank you for a quick response. After posting the issue, I'd not used CH until now. It is fixed, thank you very much.

      1. re: janniecooks

        So glad, thanks for letting us know. And sorry for the glitch.

    2. The back button is malfunctioning again. Open a thread, read the posts, hit back and the page is refreshed as if I opened it. I would expect back to return the page to the state it was in when I opened a thread.

      1 Reply
      1. re: janniecooks

        i'm getting it too - noticed it because I was going 'back' and when I got to the previous page, I was not logged in anymore.

      2. Thanks for your reports, we'll take a look.

        1. When I hit the back button it doesn't do anything at all. Chowhound is the only site that acts that way (that i've tried).

          1. I never use the back button; with Chowhound I find it much easier to right click the link to open it in a new tab.