HOME > Chowhound > Cookware >

fagor duo pressure cooker - the yellow indicator doesn't come up

m
mcquinn Apr 8, 2013 01:56 PM

I keep having the same problem w/my new Fagor Duo Pressure Cooker - the yellow indicator doesn't come up! after 15/20 minutes, with no sign of the indicator coming up, water begins to drip from around lid. but after awhile, i realize something is wrong and open up the pressure cooker to discover either my meal is undercooked or burned.

i followed everything in the FAQ: I oil the lid and press down when i close. I lock the lid of course and put it on setting 2 (high).

any advice? anyone else with this problem?

the result is that i have to open up the pressure cooker before I can even begin to start

  1. Click to Upload a photo (10 MB limit)
Delete
  1. t
    thimes RE: mcquinn Apr 8, 2013 02:49 PM

    I am a relatively recent pressure cook-er, so I can only give you my experiences as a new user. I also have a Fagor Duo for what that is worth - I have the larger model (10qts maybe?).

    What I have "learned" using mine and from reading other posts on here about other's experiences . . . .

    1) it takes a while to come to pressure - the old adage of "a watched pot never boils" is even more true with my pressure cooker. Even when I put the lid on when the liquid is boiling it takes a little while until the yellow thing pops up and it comes to pressure. I've found that the less water I have the longer it takes - my guess this is the physics of pressurizing a larger air space.

    2) I've found that I have quite a bit of time where "steam" is leaking from around the handle, I get some condensation under the handle which sometimes drips onto the burner, sometimes it comes from around the "pressure gauge" knob/dial - this means that it is still coming to pressure and if I just keep letting it go it eventually starts only coming out of the little spout looking thing on the knob/dial. That is when it is at pressure.

    3) when I've had problems (and I haven't had as much as others seem to have had), I find if I take the lid off and wiggle the underside of the yellow indicator it all seems to work fine. I've taken to wiggling it every time now before I put the lid on and it has been fine every time.

    4) the only thing I've burned in my pot so far was a tomato sauce and it only really scorched on the bottom edge of the pot - where the pot goes from the heavy base to the thinner edges. I think i just wasn't centered over my gas burner. It has only happened once and now I just make sure my gas flames don't go up the side too much.

    It is a shame to waste food. Have you tried just filling your pressure cooker to maybe an inch below the "full" line, bringing it to a boil, put the lid on, and see what happens. You might be more willing to "let it go a little longer" knowing there is only water in your pressure cooker and nothing is going to be ruined . . . . .

    1. s
      sueatmo RE: mcquinn Apr 8, 2013 04:54 PM

      I suspect you are not locking the lid after lidding the pot. The cooker won't come up to pressure if the lid isn't locked.

      When I was first learning my Fagor, I had that problem. I would forget to slide the lock on the top of handle forward. Or, I would forget to make sure that the pressure valve was closed. (I was used to an old fashioned pressure cooker with the jiggly pressure regulator.)

      1. Chemicalkinetics RE: mcquinn Apr 8, 2013 05:01 PM

        Few very basic but essential things to check.

        First, do you have the gasket? Because you need the gasket, and my first Fagor came to me without a gasket.

        Second, did you turn and lock the lid into place?

        Third, did you lock the lid in with the yellow button?

        Good luck.

        1. paulj RE: mcquinn Apr 8, 2013 11:46 PM

          My Fagor has been finicky like this - the yellow buttonn not rising, or rising followed by dripping around the lid. Sometimes opening it and resitting the lid helped. But the other day I noticed that the gasket was not seated evenly all the way around. I adjusted it so the top and bottom edges of the gasket were aligned, put the lid back on, and presto the button rose almost as quickly as on my old Presto.

          I just tried it again, with an inch of boiling water in the pot, and it came up to pressure without problem. So it looks as though correct gasket placement is the trick.

          My suggestion is to practice with plain water in the pot, paying special attention to the gasket and its alignment with the pot's rim. And don't try cooking food until you get the hang of it.

          1 Reply
          1. re: paulj
            paulj RE: paulj Apr 9, 2013 05:03 PM

            Another idea:
            take the gasket out of the lid and lay it on the rim. This will give you an idea of how it is supposed to fit. There isn't much room for error.

          2. m
            missh RE: mcquinn Aug 3, 2013 04:48 PM

            Did you ever figure this out? I've been having the same problem - and I've checked my gasket and made sure I'm locking it.

            1. h00kemh0rns RE: mcquinn Aug 11, 2013 04:31 PM

              I had this same exact issue. What I did was to bring whatever I wanted up to temp/to boil. Placed the lid on, locked it, then chose the setting. Once steam and water began leaking I simply pushed down on the lid to get a better seal. Just enough pressure until the yellow indicator popped up.

              1. h
                hankstramm RE: mcquinn Aug 11, 2013 10:31 PM

                This isn't normal. I have two an 8qt and a 4qt (think that's their measurements). Anyway, I've never had this problem. I'd check the gasket or just be patient. Sometimes it takes 20 mins plus to pressurize.

                1. b
                  Big_Bill RE: mcquinn Aug 11, 2013 11:29 PM

                  I've just finished trawling the web for this one (having had the same issue) and have an answer - it worked for me - see if it works for you.
                  1. Get the soup/casserole/whatever on a rolling boil
                  2. Put the lid on while still boiling
                  3. Push the yellow lock button
                  I'd not done 1 & 2 above - made a huge difference!
                  Let me know!

                  1. a
                    AdamK RE: mcquinn Oct 17, 2013 09:19 AM

                    I have had similar problems, and found one helpful solution. If the pressure cooker is leaking steam (especially around the valve) and the yellow indicator won't come up, try pushing up on the lock switch. I found that just giving it a little nudge further towards the lock position caused the seal to set and then the pressure cooker came up to pressure. Now, this was about a year ago that I discovered this, and haven't used the cooker since that time. Today I pulled it out, and am having the problem where it leaks steam out of the gasket by the side safety valve! I'm guessing this is from a misaligned gasket as other responders have indicated. However, the yellow indicator is up and pressure is building to a "level 1" setting, just not "Level 2". Oh well. Time to keep experimenting!

                    1. h
                      HC in pasadena RE: mcquinn Feb 23, 2014 11:12 AM

                      I have had the same problem. If I jiggle the pressure indicator before locking the lid, it pops out when it's supposed to.

                      1 Reply
                      1. re: HC in pasadena
                        paulj RE: HC in pasadena Feb 23, 2014 11:45 AM

                        Mine has worked better since I bought a new gasket. The old one didn't look or feel bad, but the new one seats better.

                      Show Hidden Posts