HOME > Chowhound > Site Talk >

Discussion

is anyone else having an issue with the "back" arrow?

  • 7
  • Share

I have been unable to use the back arrow in chrome to return to a previous page.

  1. Click to Upload a photo (10 MB limit)
Delete
Posting Guidelines | FAQs | Feedback
Cancel
  1. it's working, now.

    1. occasionally but I found that if I hit the refresh button when this happens the back arrow also works again.

      lots of flukey things happen with Chrome.

      4 Replies
      1. re: HillJ

        i didn't have problems with any other websites or pages, only with chow. i did hit refresh multiple times, but it didn't matter. it was odd, within minutes of posting my message, the back button was in working order here on chow.

        1. re: Vidute

          You experience is similar to my own, for some reason the flukey experience navigating CH is unique-I don't experience the same thing using the back button or refresh anywhere else.

          1. re: HillJ

            There was once an ad which was causing something very similar on Internet Explorer. If you see this again please let me know, and try to get a screen grabs of all 4 ads on the page.

            1. re: meshane

              Will do.
              On a positive, the sign in has been working lately on Chrome; no need to log back in each time.
              And, the edit tab hasn't required refreshing the entire page in order to fix a typo or change a word within a comment box...while logged into any browser.

      2. yes, with Firefox here. back button seems non-functional. I don't think it worked in the office either on IE.