HOME > Chowhound > Cookware >

Discussion

Fissler Pressure Cooker

  • 3

I just bought a Fissler pressure cooker and attempted to test it according to the manual directions. I filled it half full of water and brought that to a boil, attached the lid and then waited for the automatic valve to close.....and waited...and waited. Just to see if I was crazy I ran a timer and after 10 minutes it still hadn't reached the first pressure level. I checked the valves for adequate movement, removed and reset the gasket etc. Am I not waiting long enough or does this sound like one of the valves is defective?

  1. Click to Upload a photo (10 MB limit)
Delete
  1. It depends on the model, but according to my measurements the Fisslers are so thick they can take anywhere from 14 to 17 minutes to reach pressure!

    Put it on maximum heat, and wait!

    Ciao,

    L

    1 Reply
    1. re: pazzaglia

      At the suggestion of Fissler USA's phone support I tried just 3 cups of water and still couldn't get the indicator to rise or the euromatic valve to shut.

      I've been following the manual's directions of an appropriately sized burner, having the handle in the pressure position and using the highest heat setting that keeps the flame under the pot until pressure has been reached. My higher BTU burner gets steam coming out rapidly in ~3 minutes or so but the valve never closes to retain the pressure. Hopefully they'll be able to send me a replacement part.

    2. Have you tried to manually move the pressure valve to see if it moves at all?

      Good luck. It's a nice heavy pressure cooker and hopefully you will get this resolved.