HOME > Chowhound > Cookware >

Discussion

Moka Pot: All steam, no happy juice =(

  • 5
  • Share

I have a little moka pot and use Lavazza Crema E Gusto (which, according to the pictures on the package, works for all kinds of coffee including moka pots and espresso machines).

When I put my stove on high, I get coffee (it's a bit tinny and bitter) but anything less (medium or low, like all the directions tell you) all that happens is steam comes out the top until the bottom chamber is completely empty. I've googled this, but apparentlz I'm the only person on the internets to have had this problem.

Please advise - Thank you!

  1. Click to Upload a photo (10 MB limit)
Delete
Posting Guidelines | FAQs | Feedback
Cancel
  1. The only thing I can find is

    http://www.fixya.com/support/t1538514...

    Never had the problem myself. Might check to make sure it is sealing properly, you might have the same problem.

    1. If you're getting the full amount of juice while it's on high, then I wouldn't worry about it. If you're only getting half of the coffee you should, I imagine there is some kind of leak.

      1. It seems like this would be physically impoossible unless some of the parts were either damaged or missing. The best option would be to take it to a knowledgeable coffee shop or kitchen store & ask them if it's complete. Otherwise, posting a few pics here might be helpful in evaluating your problem (emphasis on "might").

        1. You are using the rubber gasket, right? And screwing the top and bottom togehter tightly?

          1. I think I may have been screwing the chamber/pot together wrong (didn't think that was possible) but, at least the last couple of days, I've been doing it very carefully and tightly and it's working just fine. Thanks for all the tips!