HOME > Chowhound > Site Talk >
What have you made lately? Share your food adventure
TELL US

Edit function not working

h
HillJ Jul 3, 2012 05:40 AM

Anyone else experiencing this today?

On three diff boards this morning, I went back in to edit, add a comment, and the entire comment disappeared and a #html/script? appeared. I had to refresh in order to retrieve my original comment but could not add or change the original within mins. of writing it.

thanks.

  1. mudaba Jul 9, 2012 04:54 PM

    Has this issue improved for everyone? I have tried to replicate it since today's release, and am not seeing it happen anymore. Fingers crossed that is true for the people on this thread as well?

    Let me know and thanks, Meredith

    1 Reply
    1. re: mudaba
      huiray Jul 10, 2012 04:47 AM

      So far so good today... I've made three edits in posts on three different threads and it seems to be working properly so far. That #{htmlSnippet} is not appearing and the edited post appears correctly after the save. Thanks.

    2. j
      John Francis Jul 6, 2012 04:35 AM

      Today the Edit/Save function is working as it should, in all the boards I've looked at this morning. Looks like the problem is solved.

      5 Replies
      1. re: John Francis
        huiray Jul 6, 2012 06:15 AM

        Not for me. I've dumped the caches from my browsers repeatedly, including deleting the *entire* FF or Google folders from the Caches folder in my Library folder in my userID folder; not merely emptying the caches --> hence forcing the browsers to rebuild their cache folders entirely from scratch when I restart the browsers. I've also tried rebooting my computer several times. The problem persists for me. :-(

        A couple of screenshots - in Chrome, after a dump of the entire Google folder in the Cache folder and restarting the browser - a short while ago. 1st screenshot is after an edit+save. 2nd screenshot after edit+save+reload of the page.

        @Engineering:
        What about the 'file' or 'jar' folders in my Java folder with this path: [myuserID] --> Library --> Caches --> Java --> cache --> javapi --> v1.0 --> file [or] jar ? I'm not sure if dumping either of those would affect my global Java functionality though?

         
         
        1. re: John Francis
          al b. darned Jul 8, 2012 02:57 PM

          Not for me, either. Still getting #{htmlSnippet} after saving an edit. Refreshing the screen gets me the edited post, but still getting the weird tag first.

          1. re: al b. darned
            j
            John Francis Jul 8, 2012 04:23 PM

            Meanwhile, the problem has stayed fixed for me. Using Firefox, fully updated, with Windows XP, fully updated; made no changes in setup or add-ons before the problem went away.

            1. re: John Francis
              huiray Jul 8, 2012 05:22 PM

              It worked for me part of yesterday, then stopped working again. I just checked again using a new test post and editing it - the #{htmlSnippet} error is persisting again.

              You are obviously on a Windows PC.

              I am on a Mac. Don't know about al b. darned.

              1. re: huiray
                al b. darned Jul 8, 2012 06:22 PM

                XP and Firefox

        2. Engineering Jul 3, 2012 12:21 PM

          This is now fixed. Thank you for your patience.

          9 Replies
          1. re: Engineering
            huiray Jul 3, 2012 02:35 PM

            Nope, not fixed.

            I just edited a post of mine about 5 minutes ago and the edited post still shows only
            #{htmlSnippet}
            as the entire body of the (edited & saved) post and it still requires a reload/refresh for the edited post to appear.

            1. re: huiray
              Engineering Jul 3, 2012 04:49 PM

              It's possible that the Javascript involved is cached on your system. Could you please clear your browser cache and let us know if that resolves the problem?

              1. re: Engineering
                huiray Jul 3, 2012 05:07 PM

                Did that. Still does not work.
                What I did:
                1) cleared the cache from within "Preferences" by emptying the cache --> then tried editing a post --> (Edit#1) --> get the #{htmlSnippet} as the entirety of the edited post.
                2) Quit FF, deleted the ENTIRE cache for FF from my Profile, restarted FF (which means the browser rebuilds the cache from scratch), logged back on to CH, edited that same post again --> (Edit#2) --> still get the #{htmlSnippet} as the entirety of the post, and I need to hit 'refresh' to get the edited post. [In fact, as I am editing this post, the phenomenon is asserting itself repeatedly]

                 
                 
                1. re: Engineering
                  HillJ Jul 3, 2012 08:18 PM

                  Just made a small edit and it worked like a charm.

                  1. re: HillJ
                    huiray Jul 4, 2012 04:57 AM

                    I edited a new post of mine around 7:33 am, and another new post at 7:54 am - both this morning, 7-4-2012. Still getting #{htmlSnippet} as the entire body of the post after saving the edited post. Stlll need to hit refresh to get the edited post to appear.

                    1. re: huiray
                      HillJ Jul 4, 2012 05:43 AM

                      Sorry to hear that. I'm no longer having trouble editing comments.

                  2. re: Engineering
                    huiray Jul 4, 2012 07:50 AM

                    Test post, in Chrome.
                    edit1

                    1. re: huiray
                      huiray Jul 4, 2012 07:59 AM

                      Screenshot of page w/ time in top bar, after edit1 and save. Done today 07-04-2012.

                       
                      1. re: huiray
                        huiray Jul 4, 2012 08:01 AM

                        Screenshot of page w/ time in top bar, after edit1 and save followed by a page reload. Done today 07-04-2012.

                         
              2. Engineering Jul 3, 2012 09:43 AM

                Are you certain that your edits aren't going through? In my experiments thus far, the edit is saved despite the incorrect #{html_snippet} text being displayed until I reload.

                In either case, we're investigating the problem and hope to have it fixed soon. Our apologies for the inconvenience.

                1 Reply
                1. re: Engineering
                  HillJ Jul 3, 2012 09:58 AM

                  They weren't in 3 comments I made much earlier today. I opted to just add the comment to a new line rather than try to figure it out. If I run into this issue again, I'll post it here.

                2. huiray Jul 3, 2012 07:34 AM

                  Yes, this is happening to me too. I can edit a post but after saving it I get the #{htmlSnippet} in the post window (and nothing else) as you do. On refreshing the page I got the original post (I think) about 2 hours or so ago, but got the edited post (on another thread) a little later onwards. In the first case I actually copied the edited post and reposted it, then asked the mods to delete the previous post which just showed #{htmlSnippet}.

                  2 Replies
                  1. re: huiray
                    j
                    John Francis Jul 5, 2012 09:22 AM

                    Now, when you refresh the page, you should see your edited post, not the original unedited one. But it's still disconcerting and annoying not to see it when you click the SAVE button, as it used to be.

                    This is using Firefox, Results may differ for those using other browsers, I don't know.

                    1. re: John Francis
                      huiray Jul 5, 2012 10:01 AM

                      Yes, I see the edited post after saving and refreshing. Just 'saving' shows the #{htmlSnippet} as the body of the post, as I have described, in FF. I gather you also see this. :-)

                  2. Gio Jul 3, 2012 05:49 AM

                    LOL... it just happened to me. It's been a morning of crazy PC happenings so I thought I was having another dispute with the computer devils.

                    2 Replies
                    1. re: Gio
                      HillJ Jul 3, 2012 05:56 AM

                      Gio, ALWAYS nice to have a fellow CH back me up, rofl...

                      1. re: HillJ
                        Gio Jul 3, 2012 06:08 AM

                        Yup... gotcha back, HillJ...

                    Show Hidden Posts