HOME > Chowhound > Site Talk >

Discussion

Broken Links for COTM Titles

  • JoanN Sep 30, 2011 05:14 AM
  • 14
  • Share

Was just looking for a review of a recipe in The Slow Mediterranean Kitchen, the January 2008 COTM, and all the links to the various threads I clicked on from the main page ( http://chowhound.chow.com/topics/474978 ) were broken. I did a quick check of two other COTM titles from the archived list, and the links for the Frank Stitt seem to be broken as well, although the links for Sunday Suppers was working.

This could be a small disaster for those of us who have been with COTM from the beginning and rely on those links to find posted reviews. Hope this is something that can be fixed quickly and easily.

  1. Click to Upload a photo (10 MB limit)
Delete
Posting Guidelines | FAQs | Feedback
Cancel
  1. Actually, it seems all embedded links, even to the discussion you linked, are not working. Someone in Chow did something....

    3 Replies
    1. re: Karl S

      No, not *all.* As noted above, the embedded links for Sunday Suppers ( http://chowhound.chow.com/topics/397079 ) is working.

      1. re: JoanN

        It wasn't when I clicked on it. I got the same error message I've been getting on a variety of other links displayed like that.

        1. re: JoanN

          Just started checking other titles, but it was too depressing to continue. Hazan, Stevens, Bayless, Greenspan--the first four COTMs--all broken.

      2. JoanN... Engineering knows about it... they did some site maintenance yesterday...
        http://chowhound.chow.com/topics/809822

        2 Replies
        1. re: Gio

          Thanks, Gio. I hadn't seen that. Thought, at first, that it was just COTM and was a bit freaked out.

          1. re: JoanN

            CH was in "washing dishes" mode about 1/2 hour ago. The hyperlinks in posts with paragraph returns preceding it all seem to work again now.

            In any case, previously when the links were "broken" one could still access the webpage the link pointed to - one just had to manually remove the stuff the site demon had added to the actual URL - see http://chowhound.chow.com/topics/7424... .

        2. Okay. So some of the embedded links are working now. But if you go to the main COTM archive page ( http://www.chow.com/cookbook_of_the_m... ), some links to the posting threads are now broken. I went through the first year and couldn't link to Bayless, Greenspan, Rodgers, Goin (which worked perfectly well before), or Schlesinger.

          4 Replies
          1. re: JoanN

            They seem to work now.

            1. re: huiray

              The links to the main threads seem to be working now, but many of the embedded links within the main threads still don't.

              1. re: JoanN

                I was wondering if you could provide examples.

                Did those embedded links load correctly before?

                Nevertheless, I pulled up that Bayless book thread (http://chowhound.chow.com/topics/339027) (one of the ones you were complaining about) and tried some of the URLs in the first (OP) post - is that what you mean? OK, those don't work, but it looks like the format is wrong, not due to a bug in the latest "washing dishes" episode.

                The first embedded link in the Bayless thread is http://www.chowhound.com/topics/show/... . However, I believe the format used by CH now is one where the /show is NOT present. Just look at the URL for ANY thread currently on CH - for example, the URL for this thread is http://chowhound.chow.com/topics/809928 . If I let that embedded thread in the Bayless book thread load with the error message turning up, then go to the URL and manually delete /show to give http://www.chowhound.com/topics/339023 then hit return the appropriate page loads.

                I note that the thread (and posts) date from 2006. - perhaps the format then was with the /show present? If so, then all those embedded links with /show in the URL will presumably not load the intended page correctly, and all will have to be manually updated, unless CH had a subroutine coded in to direct those old hyperlinks containing /show to the correct "new" URLs - and the last 'washing dishes' messed that up?

                ETA: In fact, it looks like only the last three (the earliest three) entries on the main page of COTM [Hazan, Sept 2006; Steven, Oct 2006; Bayless, Nov 2006] have threads with embedded URLs to CH threads that contain /show in the URLs. All the others later than these three do not, and the embedded links to CH threads work, at least the random selection that I have tried. The embedded links in the Greenspan thread [Dec 2006] work fine.

                1. re: huiray

                  I see what you mean about /show. And indeed most of the links are working this morning, many more than did last time I checked yesterday evening.

                  And yes, those earlier links from '06 used to work. I was looking for a Bayless report just a few weeks ago and had no difficulty accessing it.

                  Since the broken links are now just down to a few titles and you've identified the problem, those links should be easy enough to clean up by hand.

          2. Embedded links for the first three COTMs (Hazan, Stevens, & Bayless) are still broken, evidently because of the addition of /show in the url. Could someone with access please go in and fix them by hand.

            1 Reply
            1. re: JoanN

              We are working on a blanket fix to track down links with the erroneous /show and clean them up en masse. Our apologies for the delay. The workaround, in the mean time, is to simply remove "show" from the path.

              Thank you for reporting this issue initially, as well as your patience while we work out the fix.