HOME > Chowhound > Site Talk >

Discussion

Duplicate restaurant loop

  • 8

When adding a new restaurant and the duplicate restaurant message appears, hitting the "add restaurant" button just loops back to the error message.

To tell you the truth, I don't know if records are being added or not. Search, as mentioned in another post, is not working. Records that are in the database are not appearing no matter how I search. I've been catching up on updating the database today and it has been a major challenge.

Back to this problem ... which also happened on a few other records I didn't note.

I searched for LA Deli in Antigua, Guatemala. There were two locations in Gautemala City, none in Antigua. So I added it and got the duplicate message attached. Ironically none of the displayed restaurants was La Deli. It seems to pick up every restaurant that has "La:" in the name ... good luck with that in Gutemala.

The restaurant could not be added. It just loops.

\I thought I had added it in the past. Going to Google, I found the record.

http://www.google.com/search?q=Antigu...

http://www.chow.com/restaurants/92223...

You could argue, that I didn't put the name in quotes, but it did turn up the two other records without the quotes. Going back and searching with quotes ... same results ... two Guatemala City restaurants and none in Antigua.
http://www.chow.com/search?query=%3A%...

Since I'm here, it would be nice if somewhere in the future the colors on the duplicate records was changed. I simply cannot read that tiny dark blue print against the redo background. I have to cut and past that information to read it.

There are about a half dozen records I've had similar problems with.

 
  1. Click to Upload a photo (10 MB limit)
Delete
  1. >> Search, as mentioned in another post, is not working. Records that are in the database are not appearing no matter how I search. I've been catching up on updating the database today and it has been a major challenge.

    As noted at www.chow.com/topics/801171 the restaurant database was not getting refreshed. Engineering reported there that they were aware of the problem and they were working on it.

    During that period, from what I could tell, search WAS working just fine, but results were based on the most recent version of the restaurant database which had not been refreshed. So you wouldn't be able to search on anything that changed in the previous couple of days, but other than that, it was working fine.

    Last night, the refresh of the restaurant database began working again. So you might want to try it again, and see if everything is working properly now.

    7 Replies
    1. re: nsxtasy

      Yes, I am more than aware of the issue with search you mention.

      However these records were not entered recentlly, but montths ago, so refresh is not the issue, but search is.

      It makes it really difficult because I cant remember if I really did enter a record or search is failing. I'm catching up with a lot of restaurant records so having to do a google search in addition to a number of Chowhound searches to find records is a major PITA.

      When I click on the link in the OP searching for La Deli in Antigua, it now displays. Whether that is the result of making updates to it over the past few days I have no clue.

      HOWEVER ,.. the loop error still remains.

      If I try to add another record for La Deli in Antigua GT, it displays the error message and will not let me override it.

      It is often likely there are duplicate restaurant names in the same city. Within a one block area there are three frestaurants called La Fonda de la Calle Real.

      In the past I could override the error message and add the addtional records. I can no longer do that.

      My work around is to enter a bogus restaurant name, create the record, then change the name. While I know I can beat the system this way, most people would not know that

      This is something new. In the past, you could override the duplicate message.

      1. re: rworange

        Yesterday I got a duplicate message when trying to add a similar named restaurant in the same town as an existing one. No problem clicking through to override and the new record was created.

        1. re: Melanie Wong

          US or international?

          Again, I'm not that crazed about records outside the country. There seem to be some different things that happen though. Just wanted to report this to note it if anyone else has this problem.

          Yesterday was really the pits in trying to add and update Guatemalan restaurants. Still, if i can work around it, fine. My highest priority is being to enter a record period. However, when this happened on quite a few records ... fffttt .. I thought I'd report it.

          As of this post, I still cannot override the duplicate record message. It just loops back to the message. I have to play around with the info to get the info entered.

          1. re: rworange

            The record I entered yesterday was in the US, not international. And in case it helps, I had put in only city and state for the address when I got the duplicate message. I was using Firefox. Tried using Safari not too long ago when adding a record and it hung up, spinning and spinning for a long while, but finally took.

            1. re: Melanie Wong

              No, spinning icon problem

              Hit the add button and all that happens is the duplicate record message gets redisplayed. As reported in the OP and title, it is looping back to that message.

              1. re: rworange

                With regards to the looping: I've been unable to reproduce this in our testing environment thus far. Is this happening every time you get the duplicate warning, or only in certain cases? And it's a long shot, but have you tried any other browsers?

                With regards to search record missing in search: this is admittedly strange. There are a number of issues with the search tool (even ignoring the updating problems over the weekend), but at minimum it should recognize a restaurant that's been called up by name. Searching in location "Antigua, Sacatepequez" seems to work, but that's still odd...

                1. re: Engineering

                  Hmmm ... I gave it one more try and for some reason it started to work and stopped looping.

                  The loop problem was my big issue and for whatever reason it resolved. I just haven't been paying close attention to search because of the other post about the refresh so I wrote it off as something that was going to get resolved.

                  I haven't done much work in the restaurant db since May. At that time while I might not get records by searching for the restuarant in Antigua, Guatemala, they always showed up if I just entered "Guatemala".which was good enough for me. This was the first time that failed and it failed on a number of records. I'll see how it goes over the next few days.

                  I really appreciate engineering responding not only to this issue but everyone's recently.