HOME > Chowhound > Site Talk >

Recipe links don't work in Firefox but they do in IE

j
jackiecat Dec 6, 2008 01:28 PM

When I was tried to get to the recipe links from

http://www.chow.com/stories/10812

using Firefox 3.0 I get a blank page.

Using Internet Exporer 7 the pages recipe pages load correctly.

I'm not having a problem so far with other Chow pages or other sites.

Using Vista, in case that makes a difference.

  1. Click to Upload a photo (10 MB limit)
Delete
  1. Jacquilynne RE: jackiecat Dec 7, 2008 09:38 AM

    Hrmm, I tried testing this, and I'm able to get them in both Firefox and IE, but only if I'm logged OUT. If I'm logged in, I get a blank page.

    Can you check if that's the same for you, jackie, and I'll raise a problem ticket for Engineering.

    -- Jacquilynne, Community Manager for Chowhound

    2 Replies
    1. re: Jacquilynne
      j
      jackiecat RE: Jacquilynne Dec 14, 2008 03:26 PM

      That's exactly what happens - blank page when logged in, works fine when logged out.

      Great detective work Jacquilynne!

      1. re: Jacquilynne
        sharonanne RE: Jacquilynne Dec 14, 2008 03:50 PM

        Still no fix on this? Gets annoying logging in and out. I see the last post on the update on technical problems thread is from August.

      2. t
        taos RE: jackiecat Dec 14, 2008 06:42 PM

        Same problem in Safari
        Version 3.1.2
        Mac OS X 10.5.4

        Blank screen for recipes unless I log out.
        My workaround is to search for recipes while logged in in Firefox, then switch over to simultaneously running Safari, unlogged in, past in URL and read the page. Not an ideal fix but it work for now.

        1. Chuckles the Clone RE: jackiecat Dec 14, 2008 10:32 PM

          The problem seems NOT to be related to the particular browser. Here are the
          server headers returned when a logged-in user requests a recipe page. Zero-length
          content no matter what the user-agent:

          --2008-12-14 23:21:19-- http://www.chow.com/recipes/11132
          Resolving www.chow.com... 204.2.160.226, 204.2.160.242
          Connecting to www.chow.com|204.2.160.226|:80... connected.
          HTTP request sent, awaiting response...
          HTTP/1.0 200 OK
          Server: Apache
          X-Powered-By: Phusion Passenger (mod_rails/mod_rack) 2.0.3
          Content-Length: 0
          nnCoection: close
          Content-Type: text/html; charset=utf-8
          Expires: Mon, 15 Dec 2008 07:21:19 GMT
          Cache-Control: max-age=0, no-cache, no-store
          Pragma: no-cache
          Date: Mon, 15 Dec 2008 07:21:19 GMT
          Connection: keep-alive
          Length: 0 [text/html
          ]Saving to: `STDOUT'

          [ <=> ] 0 --.-K/s in 0s

          2008-12-14 23:21:19 (0.00 B/s) - `-' saved [0/0]

          1. Chuckles the Clone RE: jackiecat Dec 15, 2008 04:16 PM

            Working for me now.

            1. Chuckles the Clone RE: jackiecat Dec 19, 2008 10:31 AM

              Broken for me now.

              Show Hidden Posts