HOME > Chowhound > General Topics >
What's your latest food quest? Share your adventure
TELL US

Los Angeles Pizza -- Its Not in the Water [moved from L.A. board]

r
Ryan X Oct 13, 2008 05:41 PM

Pizzeria Antica, Vito's, Joe's, and Mozza all have one thing in common. They prove that its not the water that makes Los Angeles pizza generally bad.

As long as I can remember liking pizza, I remember being told New York pizza is the best because of our water. Seemed logical. But then I moved to Los Angeles and found Vito's, Joes, and the rest churning out excellent pizzas made from notorious tap water.

Finally, last Friday I tried Antica in Marina Del Rey. I ordered the margarita and, fearful we would be ejected, forced my date to do the same. How did it compare to what I had last year in Naples? The sauce was a mere smear of san marzano, just like in Naples. The cheese strewn in conservative patches, like Naples. And the crust? Yes, it was airy, pliable, and covered in wood soot, like in Naples. So much for the pizza owner in Milan who told me that his pizza was not as good as in Naples because of Milanese water.

And that brings me to the ultimate point. Why does Milan, Los Angeles, and the majority of the world's cities have generally inferior pizza? Because their restaurants make money even when they use frozen dough, cheap sauce, and enough cheese to cover up its quality. Leave the water out of it.

  1. a
    Adsvino Oct 14, 2008 06:44 AM

    Pretty much. Or to have your answer another way, watch this genius video...

    http://www.chow.com/stories/11065

    5 Replies
    1. re: Adsvino
      JEN10 Oct 14, 2008 07:55 AM

      I can never get the videos to play, any advise?

      1. re: JEN10
        Servorg Oct 14, 2008 07:59 AM

        Are you using Mozilla's firefox as your browser? It works just fine with firefox for me.

        1. re: Servorg
          JEN10 Oct 14, 2008 08:08 AM

          nope, no firefox.

        2. re: JEN10
          r
          RicRios Oct 14, 2008 10:33 AM

          Your browser must allow activex controls.
          If you use Internet Explorer, go menu Tools, Internet Options, Security, click on "reset all zones to default level".

          1. re: RicRios
            JEN10 Oct 14, 2008 07:30 PM

            THANK YOU!!!

      Show Hidden Posts