HOME > Chowhound > Site Talk >
What's your latest food project? Get great advice
TELL US

Editing places: is this expected to work?

Chuckles the Clone Jun 30, 2008 06:53 PM

I've never tried editing a place entry before about three minutes ago, so I don't
know if this was ever working, but ... On this place entry:
http://www.chow.com/places/32989
which I thought I'd attempt to correct from "restaurant" to "grocery store", since
it's not a restaurant and is a grocery store, there's something that says, "If you’re
logged in, you’ll see a button to the right that says ‘edit.’".

I am logged in. I do not see a button that says "edit".

  1. kpzoo Jun 30, 2008 08:06 PM

    I just made the fix for you. What browser are you using? I'm on Firefox 2/Mac. I know a few things are broken right now on IE 6/7-PC - like the avatar hover enlargements - maybe this is one of them.

    4 Replies
    1. re: kpzoo
      Chuckles the Clone Jun 30, 2008 08:36 PM

      Thanks for the fix!

      I'm using the sport death nightly Safari WebKit download on OS X 10.5.
      But I have the same problem with Firefox 3.

      If I am not logged in, there are three "log in to edit" buttons. If I click one,
      I go to a registration/login page (with login hidden way at the bottom???).
      I log in and instead of going back to the place page I get transported to
      www.chow.com (but that's a different bug).

      Once back to the places page, the old "log in" buttons have disappeared and
      in their place is the absence of anything.

      Pretty much everything else on the site is working with this version of safari,
      so I'm not immediately ready to blame it.

      1. re: Chuckles the Clone
        kpzoo Jun 30, 2008 08:42 PM

        Since you seem like a bit of a techie..... ;-)

        Do you see this line in the code for the edit page?

        <form method="get" action="/places/32989/edit" class="button-to"><div><input class="edit_button button" type="submit" value="edit" /></div></form>

        If you don't see it in the code, then it's likely one of the many intermittent server-side issues going on right now.

        If you do see it in the code but don't see the button itself, then it could be a client-side display issue of some sort - whether the browser or the CH code is the cause, I'm too tired at the moment to try to troubleshoot myself, but at least this would give the Engineering team a bit of info to point them in the right direction as to the source of the problem.

        Edit: oh, BTW, have you tried logging out and logging back in? That sometimes fixes login-related problems of all kinds on this site.

        1. re: kpzoo
          Chuckles the Clone Jun 30, 2008 09:01 PM

          There are three forms in the source of the page: one for google maps, one for search and one "cbsi_footer_menu" thing. That whole edit_button div is missing.

          Complete logout + cookie clearing + browser restart did not change the behavior.

        2. re: Chuckles the Clone
          Jacquilynne Jun 30, 2008 09:19 PM

          This has been a problem off and on for awhile now -- some users don't seem to get the edit buttons. We've got a ticket open with Engineering to take a look at the problem.

      Show Hidden Posts