HOME > Chowhound > Site Talk >

Discussion

Is the site slower lately?

  • 5

I've been irritated by Chowhound's sluggishness since the redesign a few weeks ago - the pages seem noticably slower to load. Used to be clicking around was pretty fast and the pages felt responsive - now it's JUST slow enough that I don't click unless I'm *really* sure a thread's gonna be interesting.

This is a shame because part of the appeal of Chowhound for me is the sense of serendipity - I'm not getting that now.

It's possible this is related to me downloading Firefox 2.0 - or something else - and I'm falsely associating it with the redesign (other elements of which I also dislike). But I don't think so - other sites don't seem slower.

Anyone else? Chowhound engineers?

  1. Click to Upload a photo (10 MB limit)
Delete
  1. I've noticed delays when loading topics but it comes and goes. It's fast today.

    I think the ads are sometimes a problem, some are slow to load and sometimes that seems to interfere with the content loading.

    Firefox is definitely not a bottleneck.

    1. I'm on dial-up, and it's incredibly slow for me. I just timed a 173 post thread(What's the best fruit you've ever eaten?), and it takes over 2 1/2 minutes for the page to load. I rarely open threads of more than about 30 posts anymore.

      (edited this post because I mis-timed it when I said it took 95 seconds)

      1 Reply
      1. re: Chimayo Joe

        They've got a smart-phone version in the works. That will probably be good for dial-up users as well.

      2. I find the threads load FASTER after the change. I notice that after editing the spinning gear hangs out for a while. Ijust hit the back button and voila, back in the sadlle again.

        1. There were a number of improments made to speed-up the loading of topics during the redesign. If you're seeing a slow-down, it could be related to your local service and not necessarily this site.