HOME > Chowhound > Site Talk >

Back button broken in Safari?

Josh Jan 24, 2007 09:52 PM

Was just posting to the "we hate avatars!!!!!1111!!" thread and after posting, clicked the back button. This resulted in my message being reposted. Did that 4 times in a row. Might want to check that out.

  1. Click to Upload a photo (10 MB limit)
Delete
  1. Josh RE: Josh Jan 26, 2007 06:51 AM

    This is still happening.

    1. Josh RE: Josh Jan 26, 2007 06:51 AM

      See?

      1. f
        Feed_me RE: Josh Jan 28, 2007 12:39 AM

        It just happened to me. I hit the back button because I used to be able to go back to the page I was on before. I hit the back button twice, so I've got my reply 3 times in a row.
        Hoping the moderators will dump my extra posts.

        3 Replies
        1. re: Feed_me
          Chris VR RE: Feed_me Jan 28, 2007 07:06 AM

          I don't see three posts from you, and I've seen other people say the same thing, with no multiple posts. I think for some reason, Safari is showing multiple posts when there aren't any.

          1. re: Chris VR
            f
            Feed_me RE: Chris VR Jan 28, 2007 03:25 PM

            Thanks! I was assuming/hoping the moderators were removing the duplicate posts.

            1. re: Feed_me
              Chris VR RE: Feed_me Jan 28, 2007 04:19 PM

              I don't *think* so. It seems to be a Safari thing. I find that using tabs (open a new tab for each thread I am interested in) works great. It would avoid the back button thing.

        2. steve h. RE: Josh Jan 28, 2007 04:34 PM

          yeah, i've experienced the same thing. I hit the back arrow and my post appears twice. i quit the browser, get back in and everything is ok. don't know why this happens. when i click on the "back to the whatever board" link this is not an issue.

          1. Engineering RE: Josh Jan 28, 2007 04:35 PM

            Thanks for the report, there is definitely an issue with Safari.

            Show Hidden Posts